Как работать с ВПР в Microsoft Excel?

v0

Функция ВПР позволяет быстро заполнить таблицы, имея в документе искомые данные. Рассмотрим этот процесс на примере Microsoft Excel 2007.


ВПР означает вертикальный поиск решений. Существует еще и ГПР — горизонтальный поиск решений, но остановимся мы именно на ВПР. С помощью этой функции можно найти данные в одной таблице с последующим их выводом в другую ячейку другой таблицы.

Работать ВПР будет при наличии двух условий:

  1. Если в сопоставляемых элементах есть одинаковые элементы.
  2. Если сопоставляемые данные в первой таблице будут отсортированы по возрастанию.

Примером будет являться изображение чуть ниже.

v1

Как видно, в первой таблице данные в колонке «Сумма» идут по возрастанию, а во второй таблице присутствуют те же фамилии, что и в первой. Список фамилий во второй таблице может быть неполным, а также они могут располагаться в произвольном порядке.

ВПР в этом случае поможет заполнить пустые ячейки колонки «Сумма» второй таблицы. Конечно, если таблицы небольшие, данные можно прописать и вручную, но с огромными таблицами придется повозиться. ВПР же поможет сократить время заполнения.

Чтобы во вторую таблицу вставить сумму, выбираем нужную ячейку, но первоначально на панели инструментов нужно переключиться со вкладки Главная на Формулы. Исходя из примера, нужно выделить пустую ячейку напротив фамилии «Иванов» во второй таблице (В11). В ней нужно поставить знак равенства и на панели инструментов выбрать кнопку Вставить функцию. Откроется Мастер Функций. В разделе Категория «10 недавно использовавшихся» нужно сменить на «Полный алфавитный перечень», после этого в разделе Выберете функцию найти ВПР.v2

После нажатия ОК откроется еще одно окно, которое будет называться Аргументы функции. В графу Искомое значение нужно добавить фамилию, по которой будет производиться сопоставление. Для этого нужно выделить ту фамилию, рядом с которой был поставлен знак равенства. В данном случае это фамилия Иванов (А11).v3

В графу Таблица нужно добавить диапазон первой таблицы. Для этого нужно выделить все данные первой таблицы за исключением шапки.v4

В графе Номер столбца нужно поставить цифру 2. Это будет означать, что требуется перенести в новую таблицу сумму по фамилии, которая располагается во втором столбце выделенного диапазона первой таблицы. Соответственно, в зависимости от расположения таблицы, это число может быть иным. Кратко говоря, в данном случае «2» означает номер столбца в таблице (столбец В). Если данные располагаются в столбце С, то число будет не 2, а 3, D — 4 и так далее.

Теперь можно нажать ОК. Результат:v5

Теперь нужно создать абсолютную ссылку. Сделать это очень просто. Требуется обратиться к строке состояния. Для этого необходимо выделить ячейку с суммой, которая была получена через ВПР. В данном случае нужно выделить ячейку В11.v6

Теперь в строке состояния нужно найти два адреса ячеек и поставить перед ними знак $. Сравните, что было, и что стало после добавления этого знака.v7

Теперь эту формулу нужно скопировать и вставлять в остальные пустые ячейки. Это позволит быстро заполнить оставшиеся пустые области. Обратите внимание, каждый раз, вставляя формулу, нужно будет менять Искомое значение. v8То есть, если мы скопировали формулу =ВПР(A11;$A$4:$B$6;2), где А11 — фамилия Иванов, то чтобы заполнить ячейку с Сидоровым, нам нужно А11 заменить на А12. Результатом будет =ВПР(A12;$A$4:$B$6;2). Адреса ячеек нужно брать из второй таблицы, а не первой.v9


Отзывы и комментарии

1 комментарий к статье "Как работать с ВПР в Microsoft Excel?"

avatar
Анна

Большое спасибо)

wpDiscuz